const regex = new RegExp('[a-z](?=[A-Z])|[A-Z](?=[A-Z][a-z])', 'gm')
const str = `CollectibleOpen-WorldVirtual-World
BreedingCardPVP
Auto-BattlerBreedingStrategy
MinigameOpen-WorldVirtual-World
ActionSimulationSports
AdventureMMOStrategy
AdventureCasualPuzzle
Sports
CollectibleSci-FiVirtual-World
Battle-RoyaleeSportsMOBA
ActionPVPShooter
PVPSci-FiTower-Defense
ActionBattle-Royale
PVPSci-FiShooter
BreedingCollectibleMining
CollectibleDeFieSports
ActionAdventureShooter
City-BuildingCollectibleSimulation
ActionStrategy
AdventureOpen-World
BreedingRacingSports
Open-WorldVirtual-World
CollectibleIdle
ActionAdventure
CardCollectiblePVP
Battle-RoyaleFantasyMOBA
City-Building
BuildingMMOStrategy
AdventureMMORPG
ActionAdventureIdle
MOBARPGStrategy
MMORPGStrategy
CardCollectibleIdle
Open-WorldPVPRPG
DeFiMMOSpace
Collectible
CardCollectiblePVP
Auto-BattlerDeFiRPG
AdventureMMOOpen-World
CollectibleOpen-WorldVirtual-World
CollectibleIdleRPG
CardCollectiblePVP
ActionAdventurePVP
Sci-FiShooterSurvival
ActionStrategy
ArcadeMinigame
BreedingPVPRacing
MOBAPVP
ActionSports
PVPSpaceTurn-based
MMOStrategyTower-Defense`;
const subst = `\g<0> `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);