import Foundation
let pattern = #"[a-z](?=[A-Z])|[A-Z](?=[A-Z][a-z])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
CollectibleOpen-WorldVirtual-World
BreedingCardPVP
Auto-BattlerBreedingStrategy
MinigameOpen-WorldVirtual-World
ActionSimulationSports
AdventureMMOStrategy
AdventureCasualPuzzle
Sports
CollectibleSci-FiVirtual-World
Battle-RoyaleeSportsMOBA
ActionPVPShooter
PVPSci-FiTower-Defense
ActionBattle-Royale
PVPSci-FiShooter
BreedingCollectibleMining
CollectibleDeFieSports
ActionAdventureShooter
City-BuildingCollectibleSimulation
ActionStrategy
AdventureOpen-World
BreedingRacingSports
Open-WorldVirtual-World
CollectibleIdle
ActionAdventure
CardCollectiblePVP
Battle-RoyaleFantasyMOBA
City-Building
BuildingMMOStrategy
AdventureMMORPG
ActionAdventureIdle
MOBARPGStrategy
MMORPGStrategy
CardCollectibleIdle
Open-WorldPVPRPG
DeFiMMOSpace
Collectible
CardCollectiblePVP
Auto-BattlerDeFiRPG
AdventureMMOOpen-World
CollectibleOpen-WorldVirtual-World
CollectibleIdleRPG
CardCollectiblePVP
ActionAdventurePVP
Sci-FiShooterSurvival
ActionStrategy
ArcadeMinigame
BreedingPVPRacing
MOBAPVP
ActionSports
PVPSpaceTurn-based
MMOStrategyTower-Defense
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\g<0> "#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)