#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)[a-z](?=[A-Z])|[A-Z](?=[A-Z][a-z])"
Local $sString = "CollectibleOpen-WorldVirtual-World" & @CRLF & _
"BreedingCardPVP" & @CRLF & _
"Auto-BattlerBreedingStrategy" & @CRLF & _
"MinigameOpen-WorldVirtual-World" & @CRLF & _
"ActionSimulationSports" & @CRLF & _
"AdventureMMOStrategy" & @CRLF & _
"AdventureCasualPuzzle" & @CRLF & _
"Sports" & @CRLF & _
"CollectibleSci-FiVirtual-World" & @CRLF & _
"Battle-RoyaleeSportsMOBA" & @CRLF & _
"ActionPVPShooter" & @CRLF & _
"PVPSci-FiTower-Defense" & @CRLF & _
"ActionBattle-Royale" & @CRLF & _
"PVPSci-FiShooter" & @CRLF & _
"BreedingCollectibleMining" & @CRLF & _
"CollectibleDeFieSports" & @CRLF & _
"ActionAdventureShooter" & @CRLF & _
"City-BuildingCollectibleSimulation" & @CRLF & _
"ActionStrategy" & @CRLF & _
"AdventureOpen-World" & @CRLF & _
"BreedingRacingSports" & @CRLF & _
"Open-WorldVirtual-World" & @CRLF & _
"CollectibleIdle" & @CRLF & _
"ActionAdventure" & @CRLF & _
"CardCollectiblePVP" & @CRLF & _
"Battle-RoyaleFantasyMOBA" & @CRLF & _
"City-Building" & @CRLF & _
"BuildingMMOStrategy" & @CRLF & _
"AdventureMMORPG" & @CRLF & _
"ActionAdventureIdle" & @CRLF & _
"MOBARPGStrategy" & @CRLF & _
"MMORPGStrategy" & @CRLF & _
"CardCollectibleIdle" & @CRLF & _
"Open-WorldPVPRPG" & @CRLF & _
"DeFiMMOSpace" & @CRLF & _
"Collectible" & @CRLF & _
"CardCollectiblePVP" & @CRLF & _
"Auto-BattlerDeFiRPG" & @CRLF & _
"AdventureMMOOpen-World" & @CRLF & _
"CollectibleOpen-WorldVirtual-World" & @CRLF & _
"CollectibleIdleRPG" & @CRLF & _
"CardCollectiblePVP" & @CRLF & _
"ActionAdventurePVP" & @CRLF & _
"Sci-FiShooterSurvival" & @CRLF & _
"ActionStrategy" & @CRLF & _
"ArcadeMinigame" & @CRLF & _
"BreedingPVPRacing" & @CRLF & _
"MOBAPVP" & @CRLF & _
"ActionSports" & @CRLF & _
"PVPSpaceTurn-based" & @CRLF & _
"MMOStrategyTower-Defense"
Local $sSubst = "\g<0> "
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)