# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[a-z](?=[A-Z])|[A-Z](?=[A-Z][a-z])"
test_str = ("CollectibleOpen-WorldVirtual-World\n"
"BreedingCardPVP\n"
"Auto-BattlerBreedingStrategy\n"
"MinigameOpen-WorldVirtual-World\n"
"ActionSimulationSports\n"
"AdventureMMOStrategy\n"
"AdventureCasualPuzzle\n"
"Sports\n"
"CollectibleSci-FiVirtual-World\n"
"Battle-RoyaleeSportsMOBA\n"
"ActionPVPShooter\n"
"PVPSci-FiTower-Defense\n"
"ActionBattle-Royale\n"
"PVPSci-FiShooter\n"
"BreedingCollectibleMining\n"
"CollectibleDeFieSports\n"
"ActionAdventureShooter\n"
"City-BuildingCollectibleSimulation\n"
"ActionStrategy\n"
"AdventureOpen-World\n"
"BreedingRacingSports\n"
"Open-WorldVirtual-World\n"
"CollectibleIdle\n"
"ActionAdventure\n"
"CardCollectiblePVP\n"
"Battle-RoyaleFantasyMOBA\n"
"City-Building\n"
"BuildingMMOStrategy\n"
"AdventureMMORPG\n"
"ActionAdventureIdle\n"
"MOBARPGStrategy\n"
"MMORPGStrategy\n"
"CardCollectibleIdle\n"
"Open-WorldPVPRPG\n"
"DeFiMMOSpace\n"
"Collectible\n"
"CardCollectiblePVP\n"
"Auto-BattlerDeFiRPG\n"
"AdventureMMOOpen-World\n"
"CollectibleOpen-WorldVirtual-World\n"
"CollectibleIdleRPG\n"
"CardCollectiblePVP\n"
"ActionAdventurePVP\n"
"Sci-FiShooterSurvival\n"
"ActionStrategy\n"
"ArcadeMinigame\n"
"BreedingPVPRacing\n"
"MOBAPVP\n"
"ActionSports\n"
"PVPSpaceTurn-based\n"
"MMOStrategyTower-Defense")
subst = "\\g<0> "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.