#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\*\d+)+#$"
Local $sString = "*123#" & @CRLF & _
"// Must be true" & @CRLF & _
"*1*2*3#" & @CRLF & _
"// Must be true" & @CRLF & _
"*1#23#" & @CRLF & _
"// Must be false" & @CRLF & _
"***123###" & @CRLF & _
"// Must be false" & @CRLF & _
"*12**3#" & @CRLF & _
"// Must be false"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")