$re = '/^(?:\*\d+)+#$/m';
$str = '*123#
// Must be true
*1*2*3#
// Must be true
*1#23#
// Must be false
***123###
// Must be false
*12**3#
// Must be false';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);