package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\*\d+)+#$`)
var str = `*123#
// Must be true
*1*2*3#
// Must be true
*1#23#
// Must be false
***123###
// Must be false
*12**3#
// Must be false`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}