re = /^(?:\*\d+)+#$/m
str = '*123#
// Must be true
*1*2*3#
// Must be true
*1#23#
// Must be false
***123###
// Must be false
*12**3#
// Must be false'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end