use strict;
my $str = '#include <iostream>
#include <stdlib.h>
#define MAX 256
/23836//23836/Definiramo konstanto MAX
int main() {
/23836*Vstopna točka programa
Ne uporabljamo parametrov pri main, kjer jih ne potrebujemo
*23836/
printf("");/23836/izpis vrednosti konstante MAX
return 0;
}
/23836/Končamo z izvajanjem programa
/23836//23836/komentar/23836/
/23836//23836*Testni komentar/23836/ /23836* /23836/
/23836*komentar/23836/nov komentar/test/23836/*23836/
/23836*/**Kaj pa ta vzorec?*/23836* /23836**23836/
(?<=\\/23836\\/).*?|(?<=\\/23836\\*)[\\S\\s]*(?=\\*23836\\/)/gmU
((?<=\\/23795\\*).+?(?=\\*23795\\/))|((?<=\\/23795\\/)[^*].+?[\\n])
(?<=\\/23836\\/).*$|(?<=\\/23836\\*)(.*$\\n.*\\n.*\\n.*)(?=\\*23836\\/)|(?<=\\/23836\\*)(.|\\n)*(?=\\*23836\\/)|(?<=\\/23836\\*).*(?=\\*23836\\/)';
my $regex = qr/((?<=\/23836\*).+?(?=\*23836\/))|((?<=\/23836\/)[^*].+?[\n])/msp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}