$re = '/((?<=\/23836\*).+?(?=\*23836\/))|((?<=\/23836\/)[^*].+?[\n])/ms';
$str = '#include <iostream>
#include <stdlib.h>
#define MAX 256
/23836//23836/Definiramo konstanto MAX
int main() {
/23836*Vstopna točka programa
Ne uporabljamo parametrov pri main, kjer jih ne potrebujemo
*23836/
printf("");/23836/izpis vrednosti konstante MAX
return 0;
}
/23836/Končamo z izvajanjem programa
/23836//23836/komentar/23836/
/23836//23836*Testni komentar/23836/ /23836* /23836/
/23836*komentar/23836/nov komentar/test/23836/*23836/
/23836*/**Kaj pa ta vzorec?*/23836* /23836**23836/
(?<=\\/23836\\/).*?|(?<=\\/23836\\*)[\\S\\s]*(?=\\*23836\\/)/gmU
((?<=\\/23795\\*).+?(?=\\*23795\\/))|((?<=\\/23795\\/)[^*].+?[\\n])
(?<=\\/23836\\/).*$|(?<=\\/23836\\*)(.*$\\n.*\\n.*\\n.*)(?=\\*23836\\/)|(?<=\\/23836\\*)(.|\\n)*(?=\\*23836\\/)|(?<=\\/23836\\*).*(?=\\*23836\\/)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);