#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "^-"
Local $sString = "-4581-4582-4583-4584"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)