$re = '/^-/';
$str = '-4581-4582-4583-4584';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;