use strict;
my $str = '-4581-4582-4583-4584';
my $regex = qr/^-/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";