import Foundation
let pattern = #"^-"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"-4581-4582-4583-4584"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)