#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"value2":\s*\K[^\s,]*(?=\s*,)"
Local $sString = "{"value1":5.0,"value2":2.5,"value3":"2019-10-24T15:26:00.000Z","modifier":[]}" & @CRLF & _
"" & @CRLF & _
"{"value1": 5.0," & @CRLF & _
""value2": 2.5," & @CRLF & _
""value3": "2019-10-24T15:26:00.000Z", " & @CRLF & _
""modifier":[]}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")