re = /"value2":\s*\K[^\s,]*(?=\s*,)/m
str = '{"value1":5.0,"value2":2.5,"value3":"2019-10-24T15:26:00.000Z","modifier":[]}
{"value1": 5.0,
"value2": 2.5,
"value3": "2019-10-24T15:26:00.000Z",
"modifier":[]}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end