using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""value2"":\s*\K[^\s,]*(?=\s*,)";
string input = @"{""value1"":5.0,""value2"":2.5,""value3"":""2019-10-24T15:26:00.000Z"",""modifier"":[]}
{""value1"": 5.0,
""value2"": 2.5,
""value3"": ""2019-10-24T15:26:00.000Z"",
""modifier"":[]}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}