import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\"value2\":\\s*\\K[^\\s,]*(?=\\s*,)";
final String string = "{\"value1\":5.0,\"value2\":2.5,\"value3\":\"2019-10-24T15:26:00.000Z\",\"modifier\":[]}\n\n"
+ "{\"value1\": 5.0,\n"
+ "\"value2\": 2.5,\n"
+ "\"value3\": \"2019-10-24T15:26:00.000Z\", \n"
+ "\"modifier\":[]}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}