const regex = new RegExp('(?i)\\b(?=https?:\\/\\/|)(?<!clips\\.)twitch\\.tv\\/(?!minokawa95)\\b', 'gm')
const str = `twitch.tv/minokawa95
TWITCH.TV/MINOKAWA95
http://twitch.tv/minokawa95
HTTP://TWITCH.TV/MINOKAWA95
https://twitch.tv/minokawa95
HTTPS://TWITCH.TV/minokawa95
twitch.tv/notminokawa95
TWITCH.TV/NOTMINOKAWA95
http://twitch.tv/notminokawa95
HTTP://TWITCH.TV/NOTMINOKAWA95
https://twitch.tv/notminokawa95
HTTPS://TWITCH.TV/NOTMINOKAWA95
clips.twitch.tv/SampleShitSeven
CLIPS.TWITCH.TV/SAMPLESHITSEVEN
http://clips.twitch.tv/SampleShitSeven
HTTP://CLIPS.TWITCH.TV/SAMPLESHITSEVEN
https://clips.twitch.tv/SampleShitSeven
HTTPS://CLIPS.TWITCH.TV/SAMPLESHITSEVEN
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}