re = /(?i)\b(?=https?:\/\/|)(?<!clips\.)twitch\.tv\/(?!minokawa95)\b/m
str = 'twitch.tv/minokawa95
TWITCH.TV/MINOKAWA95
http://twitch.tv/minokawa95
HTTP://TWITCH.TV/MINOKAWA95
https://twitch.tv/minokawa95
HTTPS://TWITCH.TV/minokawa95
twitch.tv/notminokawa95
TWITCH.TV/NOTMINOKAWA95
http://twitch.tv/notminokawa95
HTTP://TWITCH.TV/NOTMINOKAWA95
https://twitch.tv/notminokawa95
HTTPS://TWITCH.TV/NOTMINOKAWA95
clips.twitch.tv/SampleShitSeven
CLIPS.TWITCH.TV/SAMPLESHITSEVEN
http://clips.twitch.tv/SampleShitSeven
HTTP://CLIPS.TWITCH.TV/SAMPLESHITSEVEN
https://clips.twitch.tv/SampleShitSeven
HTTPS://CLIPS.TWITCH.TV/SAMPLESHITSEVEN
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end