import Foundation
let pattern = #"(?i)\b(?=https?:\/\/|)(?<!clips\.)twitch\.tv\/(?!minokawa95)\b"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
twitch.tv/minokawa95
TWITCH.TV/MINOKAWA95
http://twitch.tv/minokawa95
HTTP://TWITCH.TV/MINOKAWA95
https://twitch.tv/minokawa95
HTTPS://TWITCH.TV/minokawa95
twitch.tv/notminokawa95
TWITCH.TV/NOTMINOKAWA95
http://twitch.tv/notminokawa95
HTTP://TWITCH.TV/NOTMINOKAWA95
https://twitch.tv/notminokawa95
HTTPS://TWITCH.TV/NOTMINOKAWA95
clips.twitch.tv/SampleShitSeven
CLIPS.TWITCH.TV/SAMPLESHITSEVEN
http://clips.twitch.tv/SampleShitSeven
HTTP://CLIPS.TWITCH.TV/SAMPLESHITSEVEN
https://clips.twitch.tv/SampleShitSeven
HTTPS://CLIPS.TWITCH.TV/SAMPLESHITSEVEN
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)