use strict;
my $str = 'twitch.tv/minokawa95
TWITCH.TV/MINOKAWA95
http://twitch.tv/minokawa95
HTTP://TWITCH.TV/MINOKAWA95
https://twitch.tv/minokawa95
HTTPS://TWITCH.TV/minokawa95
twitch.tv/notminokawa95
TWITCH.TV/NOTMINOKAWA95
http://twitch.tv/notminokawa95
HTTP://TWITCH.TV/NOTMINOKAWA95
https://twitch.tv/notminokawa95
HTTPS://TWITCH.TV/NOTMINOKAWA95
clips.twitch.tv/SampleShitSeven
CLIPS.TWITCH.TV/SAMPLESHITSEVEN
http://clips.twitch.tv/SampleShitSeven
HTTP://CLIPS.TWITCH.TV/SAMPLESHITSEVEN
https://clips.twitch.tv/SampleShitSeven
HTTPS://CLIPS.TWITCH.TV/SAMPLESHITSEVEN
';
my $regex = qr/(?i)\b(?=https?:\/\/|)(?<!clips\.)twitch\.tv\/(?!minokawa95)\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}