using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!(;|^))(?!""(;|$))""";
string input = @"1;200;345;""Apotheker ""Blue tongue"";""Apeldoorn"";12;""ABCD12""
2;232;312;""Café ""Blue Oyster"";""Rotterdam"";33;""DCBA21""
""aul"";1;200;""aap""noot"";""cafe ""'t hoekje"";piet";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}