import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<!(;|^))(?!\"(;|$))\"";
final String string = "1;200;345;\"Apotheker \"Blue tongue\"\";\"Apeldoorn\";12;\"ABCD12\"\n"
+ "2;232;312;\"Café \"Blue Oyster\";\"Rotterdam\";33;\"DCBA21\"\n"
+ "\"aul\";1;200;\"aap\"noot\";\"cafe \"'t hoekje\"\";piet";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}