const regex = /(?<!(;|^))(?!"(;|$))"/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<!(;|^))(?!"(;|$))"', 'gm')
const str = `1;200;345;"Apotheker "Blue tongue"";"Apeldoorn";12;"ABCD12"
2;232;312;"Café "Blue Oyster";"Rotterdam";33;"DCBA21"
"aul";1;200;"aap"noot";"cafe "'t hoekje"";piet`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}