$re = '/(?<!(;|^))(?!"(;|$))"/m';
$str = '1;200;345;"Apotheker "Blue tongue"";"Apeldoorn";12;"ABCD12"
2;232;312;"Café "Blue Oyster";"Rotterdam";33;"DCBA21"
"aul";1;200;"aap"noot";"cafe "\'t hoekje"";piet';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);