re = /(?<!(;|^))(?!"(;|$))"/m
str = '1;200;345;"Apotheker "Blue tongue"";"Apeldoorn";12;"ABCD12"
2;232;312;"Café "Blue Oyster";"Rotterdam";33;"DCBA21"
"aul";1;200;"aap"noot";"cafe "\'t hoekje"";piet'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end