package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d\d?:\d\d).*?(Mon(?:day)?|Tue(?:sday)?|Wed(?:nesday)?|Thu(?:rsday)?|Fri(?:day)?|Sat(?:urday)?|Sun(?:day)?).*`)
var str = `0:18 on Tuesday's mini
1:43 Wednesday. dang!
2:01 this Sat 😎`
var substitution = "$1 $2"
fmt.Println(re.ReplaceAllString(str, substitution))
}