import Foundation
let pattern = #"(\d\d?:\d\d).*?(Mon(?:day)?|Tue(?:sday)?|Wed(?:nesday)?|Thu(?:rsday)?|Fri(?:day)?|Sat(?:urday)?|Sun(?:day)?).*"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
0:18 on Tuesday's mini
1:43 Wednesday. dang!
2:01 this Sat 😎
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1 $2"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)