use strict;
my $str = '0:18 on Tuesday\'s mini
1:43 Wednesday. dang!
2:01 this Sat 😎';
my $regex = qr/(\d\d?:\d\d).*?(Mon(?:day)?|Tue(?:sday)?|Wed(?:nesday)?|Thu(?:rsday)?|Fri(?:day)?|Sat(?:urday)?|Sun(?:day)?).*/p;
my $subst = '$1 $2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";