$re = '/(\d\d?:\d\d).*?(Mon(?:day)?|Tue(?:sday)?|Wed(?:nesday)?|Thu(?:rsday)?|Fri(?:day)?|Sat(?:urday)?|Sun(?:day)?).*/';
$str = '0:18 on Tuesday\'s mini
1:43 Wednesday. dang!
2:01 this Sat 😎';
$subst = "$1 $2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;