re = /(\d\d?:\d\d).*?(Mon(?:day)?|Tue(?:sday)?|Wed(?:nesday)?|Thu(?:rsday)?|Fri(?:day)?|Sat(?:urday)?|Sun(?:day)?).*/
str = '0:18 on Tuesday\'s mini
1:43 Wednesday. dang!
2:01 this Sat 😎'
subst = '$1 $2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result