package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m:^ => \d+:\s*<% binding.pry %>.*)`)
var str = ` 64: <div class="form-group">
=> 65: <% binding.pry %> # This one should match
66: </div>
67: <% binding.pry %> # This one should not be matched`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}