$re = '/(?m:^ => \d+:\s*<% binding.pry %>.*)/';
$str = ' 64: <div class="form-group">
=> 65: <% binding.pry %> # This one should match
66: </div>
67: <% binding.pry %> # This one should not be matched';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);