// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m:^ => \d+:\s*<% binding.pry %>.*)").unwrap();
let string = " 64: <div class=\"form-group\">
=> 65: <% binding.pry %> # This one should match
66: </div>
67: <% binding.pry %> # This one should not be matched";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}