import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m:^ => \\d+:\\s*<% binding.pry %>.*)";
final String string = " 64: <div class=\"form-group\">\n"
+ " => 65: <% binding.pry %> # This one should match\n"
+ " 66: </div>\n"
+ " 67: <% binding.pry %> # This one should not be matched";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}