re = /(?m:^ => \d+:\s*<% binding.pry %>.*)/
str = ' 64: <div class="form-group">
=> 65: <% binding.pry %> # This one should match
66: </div>
67: <% binding.pry %> # This one should not be matched'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end