using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\w+_\d+_\w+_(\d+)m_Length_(([0-9]*[.])?[0-9]+)_Width";
string input = @"Footballfield_01_CampNou_108m_Length_68.5_Width
Footballfield_02_Bernabeau_105m_Length_68.5_Width";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}