import re
regex = re.compile(r"\w+_\d+_\w+_(\d+)m_Length_(([0-9]*[.])?[0-9]+)_Width", flags=re.MULTILINE)
test_str = ("Footballfield_01_CampNou_108m_Length_68.5_Width\n"
"Footballfield_02_Bernabeau_105m_Length_68.5_Width")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")