re = /\w+_\d+_\w+_(\d+)m_Length_(([0-9]*[.])?[0-9]+)_Width/m
str = 'Footballfield_01_CampNou_108m_Length_68.5_Width
Footballfield_02_Bernabeau_105m_Length_68.5_Width'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end