use strict;
my $str = 'Footballfield_01_CampNou_108m_Length_68.5_Width
Footballfield_02_Bernabeau_105m_Length_68.5_Width';
my $regex = qr/\w+_\d+_\w+_(\d+)m_Length_(([0-9]*[.])?[0-9]+)_Width/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}