package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i).*\.(test|spec|es5|es6)\.(js|bundle\.js)`)
var str = `bunle.spec.js
my.main.js
test.es6.js
te.es5.js
file.test.js
abc.js
ee.ff.abc.js
eeee.ffff.abc.js`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}