re = /.*\.(test|spec|es5|es6)\.(js|bundle\.js)/i
str = 'bunle.spec.js
my.main.js
test.es6.js
te.es5.js
file.test.js
abc.js
ee.ff.abc.js
eeee.ffff.abc.js'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end