const regex = /.*\.(test|spec|es5|es6)\.(js|bundle\.js)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\.(test|spec|es5|es6)\\.(js|bundle\\.js)', 'gi')
const str = `bunle.spec.js
my.main.js
test.es6.js
te.es5.js
file.test.js
abc.js
ee.ff.abc.js
eeee.ffff.abc.js`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}