import re
regex = re.compile(r".*\.(test|spec|es5|es6)\.(js|bundle\.js)", flags=re.IGNORECASE)
test_str = ("bunle.spec.js\n"
"my.main.js\n"
"test.es6.js\n"
"te.es5.js\n"
"file.test.js\n"
"abc.js\n"
"ee.ff.abc.js\n"
"eeee.ffff.abc.js")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")