import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*\\.(test|spec|es5|es6)\\.(js|bundle\\.js)";
final String string = "bunle.spec.js\n"
+ "my.main.js\n"
+ "test.es6.js\n"
+ "te.es5.js\n"
+ "file.test.js\n"
+ "abc.js\n"
+ "ee.ff.abc.js\n"
+ "eeee.ffff.abc.js";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}