#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x) (?s)" & @CRLF & _
" keyword1 .*? " & @CRLF & _
" (?:" & @CRLF & _
" (?: keyword1 | keyword2 )" & @CRLF & _
" (*SKIP) (*FAIL) " & @CRLF & _
" | keyword3" & @CRLF & _
" )" & @CRLF & _
" .*? " & @CRLF & _
" (?: keyword1 (*SKIP) (*FAIL) | keyword2 )" & @CRLF & _
""
Local $sString = "List of keywords :" & @CRLF & _
"" & @CRLF & _
"keyword1 = <page>" & @CRLF & _
"keyword2 = </page>" & @CRLF & _
"keyword3 = {{Infobox" & @CRLF & _
"" & @CRLF & _
"Example A:" & @CRLF & _
"" & @CRLF & _
"keyword1 = <page>" & @CRLF & _
"text to consider without keyword-Not3" & @CRLF & _
"keyword2 = </page>" & @CRLF & _
"" & @CRLF & _
"Result => do not extract (or keep or split) this part." & @CRLF & _
"" & @CRLF & _
"Example B:" & @CRLF & _
"" & @CRLF & _
"keyword1 = <page>" & @CRLF & _
"text to consider with keyword3" & @CRLF & _
"keyword2 = </page>" & @CRLF & _
"" & @CRLF & _
"Result => extract (or keep or split) this part."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")