re = / (?s)
keyword1 .*?
(?:
(?: keyword1 | keyword2 )
(*SKIP) (*FAIL)
| keyword3
)
.*?
(?: keyword1 (*SKIP) (*FAIL) | keyword2 )
/x
str = 'List of keywords :
keyword1 = <page>
keyword2 = </page>
keyword3 = {{Infobox
Example A:
keyword1 = <page>
text to consider without keyword-Not3
keyword2 = </page>
Result => do not extract (or keep or split) this part.
Example B:
keyword1 = <page>
text to consider with keyword3
keyword2 = </page>
Result => extract (or keep or split) this part.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end