using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @" (?s)
keyword1 .*?
(?:
(?: keyword1 | keyword2 )
(*SKIP) (*FAIL)
| keyword3
)
.*?
(?: keyword1 (*SKIP) (*FAIL) | keyword2 )
";
string input = @"List of keywords :
keyword1 = <page>
keyword2 = </page>
keyword3 = {{Infobox
Example A:
keyword1 = <page>
text to consider without keyword-Not3
keyword2 = </page>
Result => do not extract (or keep or split) this part.
Example B:
keyword1 = <page>
text to consider with keyword3
keyword2 = </page>
Result => extract (or keep or split) this part.";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}