const regex = / (?s)
keyword1 .*?
(?:
(?: keyword1 | keyword2 )
(*SKIP) (*FAIL)
| keyword3
)
.*?
(?: keyword1 (*SKIP) (*FAIL) | keyword2 )
/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp(' (?s)
keyword1 .*?
(?:
(?: keyword1 | keyword2 )
(*SKIP) (*FAIL)
| keyword3
)
.*?
(?: keyword1 (*SKIP) (*FAIL) | keyword2 )
', 'g')
const str = `List of keywords :
keyword1 = <page>
keyword2 = </page>
keyword3 = {{Infobox
Example A:
keyword1 = <page>
text to consider without keyword-Not3
keyword2 = </page>
Result => do not extract (or keep or split) this part.
Example B:
keyword1 = <page>
text to consider with keyword3
keyword2 = </page>
Result => extract (or keep or split) this part.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}